SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
[11.0.35 Pro] - $OBJECT()$ + $COLUMN()$ issue

 
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant View previous topic
View next topic
[11.0.35 Pro] - $OBJECT()$ + $COLUMN()$ issue
Author Message
gemisigo



Joined: 11 Mar 2010
Posts: 1580

Post [11.0.35 Pro] - $OBJECT()$ + $COLUMN()$ issue Reply with quote
The $OBJECT()$ macro seems to disregard the setting Only for objects in other schema or database when mixing it with the $COLUMN()$ macro.

I have a snippet for updating tables or just selected columns.
Code:

UPDATE $OBJECT(table)$ as u
SET
   "u."$COLUMNS(vertical,updatable)$" = "|
WHERE   1 = 1
   AND u;


If I invoke this snippet with a table from another schema (in MariaDB), the resulting code will stick the schema name in front of the table name. However, if I expand the table and select a few columns, the $OBJECT$ macro will still get the correct table name, but omits the schema name. Check this short video here, where I check the $OBJECT()$ macro alone (it won't trigger when selecting columns) and in tandem with the $COLUM()$ macro. It behaves as if I had used $OBJECT(ins_object, table)$ instead of $OBJECT(table)$.

Now those two might not have been foreseen to be used simultaneously, but they do work well together (except for this small glitch). Could you improve/fix it, please?
Thu Oct 10, 2019 9:25 am View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.