SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
1314 - A required privilege is not held by the client

 
Reply to topic    SoftTree Technologies Forum Index » 24x7 Scheduler, Event Server, Automation Suite View previous topic
View next topic
1314 - A required privilege is not held by the client
Author Message
rodrigug



Joined: 30 Nov 2011
Posts: 3

Post 1314 - A required privilege is not held by the client Reply with quote
Hi,
I'm using 24x7 Scheduler version 3.6.12
On a Windows 2008 SP2 server.
I created a task to run in the morning. Runs fine when I use the Run button or at scheduled time.
However when I try to use the Run As to make it run as account XYZ, the process fails and give this error:
Create process failed: Return code: 1314 - A required privilege is not held by the client
Please help
Thank you
Wed Nov 30, 2011 6:34 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6485

Post Reply with quote
Most likely the account selected to run the job doesn't have "Login as a batch job"
After adding that privilege, don't forgot to restart the system or logoff/logon for the privilege change to propagate.
Wed Nov 30, 2011 10:34 pm View user's profile Send private message
rodrigug



Joined: 30 Nov 2011
Posts: 3

Post Reply with quote
User does have "Log on as a batch job"
it also has
Log on as a service
Modify an object label
Act as part of the operating system
Create a token object
Mon Dec 05, 2011 4:43 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6485

Post Reply with quote
How do you run the scheduler, as a service, or as a graphical-mode application?
If it fails when you run it as a service, do you use the same account?
Tue Dec 06, 2011 9:57 am View user's profile Send private message
rodrigug



Joined: 30 Nov 2011
Posts: 3

Post Reply with quote
Graphical mode
I have not tried to run it as a service but yes I will use the same account
This is the ultimate goal, to run out as a service with this account, but since I am unable to run as another account I have not tried to run it as a service yet
Tue Dec 06, 2011 10:32 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6485

Post Reply with quote
You problems are most likely related to windows UAC.

Here is why. I think you are an administrator on that system and you launch 24x7 in admin mode manually. Whenever you use Run Now function, you run all process in the same mode and windows treats them properly. Whenever you let the scheduler start them as event or time based, it starts them in detached mode creating a new user session impacted by UAC, which ignores admin rights and treats that session as a low privileged user session.

There are 2 solutions for the described issue: (1) disable UAC or (2) run 24x7 as a service, UAC doesn't affect services.

By the way, are you aware that support for 24x7 Windows-only Edition (a.k.a. old 3.x code branch) will be end-of-life by the end of this year? We urge all users to move to the enterprise class 24x7 Multi-platform Edition 4.x as soon as possible. Not that it would make a difference for UAC, it is just you might be wasting your time playing with the very old version that is going to be de-supported very soon.

Thanks
Wed Dec 07, 2011 10:37 am View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » 24x7 Scheduler, Event Server, Automation Suite All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.