SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
Hot Keys option setting is incorrect

 
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant View previous topic
View next topic
Hot Keys option setting is incorrect
Author Message
takakou



Joined: 27 Jan 2009
Posts: 22
Country: Japan

Post Hot Keys option setting is incorrect Reply with quote
Hello.
When I try to set the key settings for the Uncomment Code, the type of key that can be selected is the bookmark key setting, which is one below. For this reason, I am unable to select the desired key setting.

I have been waiting for several years, hoping that it would be fixed someday, but I have decided that I need to come out and fix it.

It would be great if you could address this in the next update.


Mon Feb 05, 2024 7:44 pm View user's profile Send private message Send e-mail
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 7828

Post Reply with quote
Thank you for letting us know. We were unaware of this issue. I see that the key index appears to be shifted by one, the Bookmark keys are very special and the Options dialog threats them differently. In this case it incorrectly applies special key handling from "Uncomment Code" one line earlier than needed. We can certainly fixed that.

Which key do you want to use for uncommenting code instead of the default Ctrl+\ key? I can suggest how to update it in the configuration file directly so you don't need to wait for the bug fix.
Mon Feb 05, 2024 11:24 pm View user's profile Send private message
takakou



Joined: 27 Jan 2009
Posts: 22
Country: Japan

Post Reply with quote
Thank you for contacting me.

The shortcut key you want to use is ctl+shift+D.

Thank you in advance for your cooperation.
Wed Feb 07, 2024 8:15 pm View user's profile Send private message Send e-mail
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 7828

Post Reply with quote
Here is how you can enter the hot key code for Ctrl+Shift+D directly.

1. Close all SQL Assistant instances
2. Open file %APPDATA%\SQL Assistant\12.4\SQLAssist.ini in Notepad
3. In the file search for line containing [targets.22]
Make sure in the section below that line there is a line like caption=SQL Assistant Code Editor. This is to verify that you located correct section with settings for SQL Assistant Code Editor and not some other target environment. If the caption value is different, look for another section with the above caption.
4. In that section find a line with text hotUncomment=00 and in that line replace 00 with 344.

This is it. Save your changes, and restart the Code Editor.[/b]
Wed Feb 07, 2024 11:34 pm View user's profile Send private message
takakou



Joined: 27 Jan 2009
Posts: 22
Country: Japan

Post Reply with quote
Thank you. I'll try it.
Thu Feb 08, 2024 7:40 pm View user's profile Send private message Send e-mail
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.