SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
24x7 Scheduler crashes on sendin mail via Outlook

 
Reply to topic    SoftTree Technologies Forum Index » 24x7 Scheduler, Event Server, Automation Suite View previous topic
View next topic
24x7 Scheduler crashes on sendin mail via Outlook
Author Message
NNWaterworks



Joined: 20 Oct 2016
Posts: 4
Country: United States

Post 24x7 Scheduler crashes on sendin mail via Outlook Reply with quote
We are running 24x7 v 3.6.10 on a PC running Windows 7 Pro
This is a recently replaced PC for one that was running an earlier version of Windows. On the new PC Scheduler crashes when it attempts to send an email after a batch job has completed. The error messages are as follows:

Problem signature:
Problem Event Name: APPCRASH
Application Name: 24X7.EXE
Application Version: 3.4.27.0
Application Timestamp: 3cc67372
Fault Module Name: EMSMDB32.DLL_unloaded
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 57b2bf3c
Exception Code: c0000005
Exception Offset: 66ae211b
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

The Exception code c0000005 is an access violation. We expect this is a matter of a settings conflict between 24x7 and MSOutlook, but we have no idea what it might be.
I am able to open outlook and send mail from the user-id that the Scheduler uses and it works fine.

Any help is appreciated.
M. Gerlach
Thu Oct 20, 2016 4:49 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6501

Post Reply with quote
Please check if anything "interesting" appears in the scheduler's debug.log file.
In general, you shouldn't use MAPI email interface, it's inappropriate for automated jobs. you should use SMTP interface instead of MAPI.
Fri Oct 21, 2016 12:10 am View user's profile Send private message
NNWaterworks



Joined: 20 Oct 2016
Posts: 4
Country: United States

Post Reply with quote
Thank you for your prompt response.
I have set 24x7 to use SMTP and pointed it to the correct SMTP server. I set the Sender Address.
Now I am getting the attached error. The batch file has comments only, it does nothing. The function of the job is to let us know that 24x7 is still running.
This new PC is running MSOutlook Pro + 2013. The old PC had MSOutlook Pro + 2010. Are you aware of any conflicts with the new Outlook?


Fri Oct 21, 2016 11:19 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6501

Post Reply with quote
The referenced image is too small and unreadable. Please attach it again and do not select the resize option.
Fri Oct 21, 2016 1:16 pm View user's profile Send private message
NNWaterworks



Joined: 20 Oct 2016
Posts: 4
Country: United States

Post Reply with quote
Sorry. I didn't resize. My screen capture does that...

I am getting "Job started." and "Job finished." Then about 20 seconds later we get an error message that says "Notification Action Failed. The mail server does not like the sender name, have you set your mail address correctly?"

I checked with our network people, the email address is correct. ( Schedule@nnva.gov ) I am able to send mail to that address from an other machine and can send email from the 24x7 pc, without any problems or errors.

Newer info: When I run the job manually ("Run now"), the recipients do not receive an email. When 24x7 runs it automatically(by time), they do receive the email, but that Notification message still appears in the job log after about 20 seconds.
Fri Oct 21, 2016 2:07 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6501

Post Reply with quote
If that address belong to an email group or not associated with a domain account it may cause issues with authentication. The error says that there is an issue with "sender's address" not recipients.
The server may also tie authentication to the account running the process which could be a reason for you to see different results based on how you run it.

To verify if the specified email is causing that issue, run the scheduler in interactive graphical mode using your own login, create a test job sending email with your email entered in the sender's name parameter, run it and see if that works.
Fri Oct 21, 2016 5:33 pm View user's profile Send private message
NNWaterworks



Joined: 20 Oct 2016
Posts: 4
Country: United States

Post Reply with quote
Thank you for your assistance. We figured it out. The Sender's Address was "Schedule". we changed it to "Schedule@nnva.gov"
Mon Oct 24, 2016 3:27 pm View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » 24x7 Scheduler, Event Server, Automation Suite All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.