SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
[9.2.349 Pro] - Unit Testing Maximum Execution Time Bug

 
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant View previous topic
View next topic
[9.2.349 Pro] - Unit Testing Maximum Execution Time Bug
Author Message
gemisigo



Joined: 11 Mar 2010
Posts: 1401

Post [9.2.349 Pro] - Unit Testing Maximum Execution Time Bug Reply with quote
Check for Maximum Execution Time does not work (at least not for SQL Server statements). I've set the following code in Execute:
Code:

SELECT 1;
DELAY WAITFOR DELAY '00:00:05';
SELECT 2;


It obviously runs for >= 5000 ms yet Unit Testing happily reports the test case as passed, regardless of the value set for MET.
Fri Sep 01, 2017 3:31 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6509

Post Reply with quote
Thank you very much for letting us know about this issue. I have logged it under bug id #SA0032076
Fri Sep 01, 2017 4:39 pm View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.