SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
[SA 9.0.176 Pro] - Update workspace 2
Goto page Previous  1, 2
 
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant View previous topic
View next topic
[SA 9.0.176 Pro] - Update workspace 2
Author Message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6502

Post Reply with quote
Quote:
2016-11-21 10:44:34 SqlEditor64.exe Failed getting DDL: Exception has been thrown by the target of an invocation.


That sounds like some sort of .NET error. Do you get the same error in 32-bit version?
Mon Nov 21, 2016 3:03 pm View user's profile Send private message
gemisigo



Joined: 11 Mar 2010
Posts: 1397

Post Reply with quote
SysOp wrote:

That sounds like some sort of .NET error. Do you get the same error in 32-bit version?


Interesting. It works in 32-bit version. Any hints on what to try to fix it?
Mon Nov 21, 2016 3:35 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6502

Post Reply with quote
The cause of that .NET exception is unclear, the message is too generic and not very helpful. We are going to email you a link to debug version of one of the files that we want you to try. This version will dump more exception related details to SQLAssist.log file, which hopefully would reveal the root cause of the issue.
Tue Nov 22, 2016 10:31 am View user's profile Send private message
gemisigo



Joined: 11 Mar 2010
Posts: 1397

Post Reply with quote
This is disturbing. Have you fixed anything in this dll? After copying the files over the original ones (alas, I didn't save the originals) I no longer get the exception errors, the ddl-s are saved as intended. I still get some other error as you can see the log but I think that's not related to earlier errors.
Tue Nov 22, 2016 3:12 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6502

Post Reply with quote
I've been told it's one of the DLLs from 9.0.185 recompiled with additional debugging flags. That's all got.

Could that be the issue is specific to a certain database or schema object which you didn't hit this time?
Tue Nov 22, 2016 3:34 pm View user's profile Send private message
gemisigo



Joined: 11 Mar 2010
Posts: 1397

Post Reply with quote
I've sent another log with some attached comments in email.

SysOp wrote:
Could that be the issue is specific to a certain database or schema object which you didn't hit this time?


I don't think so. When failed, it failed each and every table in groups or separately, with no exceptions. This time I tried updating the workspace with the full database (no handpicking individual tables or groups of them).
Tue Nov 22, 2016 3:48 pm View user's profile Send private message
gemisigo



Joined: 11 Mar 2010
Posts: 1397

Post Reply with quote
UPDATE: I've got tables, procedures and views downloading neatly to workspace. It's now the functions that have gone renegade.
Fri Nov 25, 2016 9:42 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6502

Post Reply with quote
We hope that the debug build we sent you earlier will help us to pinpoint the root cause of the remaining issues.
Fri Nov 25, 2016 4:11 pm View user's profile Send private message
gemisigo



Joined: 11 Mar 2010
Posts: 1397

Post Reply with quote
I've downloaded and installed the debug build. All objects were downloaded to the workspace properly this time, no errors and no missing objects in Repo Browser. Log file and a video attached to the reply email.
Fri Nov 25, 2016 7:16 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6502

Post Reply with quote
The issues discussed in this topic should have been fixed in the latest released build 9.0.194. Could you please give it a try.
Fri Dec 02, 2016 1:56 am View user's profile Send private message
gemisigo



Joined: 11 Mar 2010
Posts: 1397

Post Reply with quote
Another issue emerged. Functions, procedures and views are coming as intended, tables don't, they're are throwing exceptions. I'll send the log file to support.
Fri Dec 02, 2016 6:25 am View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant All times are GMT - 4 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.