SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
[SA 7.1.246 Pro] - Assignment aligment bug?

 
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant View previous topic
View next topic
[SA 7.1.246 Pro] - Assignment aligment bug?
Author Message
gemisigo



Joined: 11 Mar 2010
Posts: 1390

Post [SA 7.1.246 Pro] - Assignment aligment bug? Reply with quote
There are some anomalies with assignment alignment. Check the following piece of code:
Code:

UPDATE   dbo.spt_monitor
SET   lastrun = 1
   ,cpu_busy = 2
   ,io_busy = 3
; -- ;#1

UPDATE   u
SET   u.lastrun = 1
   ,u.cpu_busy = 2
   ,u.io_busy = 3
FROM   
   dbo.spt_monitor AS u
; -- ;#2


The first statement is properly assignment aligned on its own. However, having any statement following it it is not aligned properly unless ;#1 is present. Otherwise, it is not assignment aligned. Also, the seconds statement is not assignment aligned regardless of ;#2.
Fri Jan 23, 2015 9:57 am View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.