SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
Job Executes Before All Semaphore Files are Found

 
Reply to topic    SoftTree Technologies Forum Index » 24x7 Scheduler, Event Server, Automation Suite View previous topic
View next topic
Job Executes Before All Semaphore Files are Found
Author Message
jeff33190



Joined: 22 Aug 2007
Posts: 96

Post Job Executes Before All Semaphore Files are Found Reply with quote
I have a job that looks for the presence of multiple semaphore files before it runs. I am testing this job in 5.1.399 and it runs as soon as any of the semaphore files arrive, rather than waiting for them all to arrive.

To test this further, I created a very simple job with a simple messagebox on run. I made the test job dependant on 2 semaphore files, again as soon as I placed either semaphore file the job ran immediately. Below is a screenshot of the job triggers properties and the log showing it running with the presence of either file1.txt or file2.txt.



Thu Apr 18, 2013 12:26 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6507

Post Reply with quote
This is a known issue, a side effect of another fix supporting use of multiple file masks in a single semaphore definition We are working on a fix, which can be released any day now.
Thu Apr 18, 2013 10:08 pm View user's profile Send private message
jeff33190



Joined: 22 Aug 2007
Posts: 96

Post Reply with quote
Glad to hear a fix is coming soon. What is the best way to know when a fix is released and what issues it addresses?
Thanks,
Jeff
Fri Apr 19, 2013 9:41 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6507

Post Reply with quote
We will notify you and post an update to this topic too
Fri Apr 19, 2013 11:09 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6507

Post Reply with quote
Hello,

Please upgrade your installation to the latest version v5.1.402 This version should fix the issue with semaphore files.

Thanks,
SoftTree Support
Mon Apr 22, 2013 8:02 am View user's profile Send private message
jeff33190



Joined: 22 Aug 2007
Posts: 96

Post Reply with quote
That appears to have fixed this issue. Thanks for quickly addressing it.
Mon Apr 22, 2013 2:15 pm View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » 24x7 Scheduler, Event Server, Automation Suite All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.