SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
Two Strange Issues

 
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant View previous topic
View next topic
Two Strange Issues
Author Message
seth.rothman



Joined: 29 Jan 2008
Posts: 42
Country: United States

Post Two Strange Issues Reply with quote
All of a sudden 2 strange things starting occuring:

1) the setting for Keywords being in Upper Case stopped working
2) code formatting stopped working

I'm 99% sure I didn't make any changes to SQL Assistant and I reconfirmed that the settings in Options are set properly (at least for #1 above). Is there anything I can check?
Thu Aug 07, 2008 11:35 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6485

Post Reply with quote
Did it stop working of all types of targets or just in a particular target environment?
Thu Aug 07, 2008 11:45 am View user's profile Send private message
seth.rothman



Joined: 29 Jan 2008
Posts: 42
Country: United States

Post Reply with quote
I only use SQL Server 2005 (SSMS). That probably would've been a helpful piece of information to share in my original email.
Thu Aug 07, 2008 11:47 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6485

Post Reply with quote
I assume you already tried to restart SSMS and it didn't help. Please let us know if SQL Assistant is run fro ma system tray or as a plug-in. If you are not sure, you can check it in Options. On the target tab, locate MS Management Studio, then expand Advanced section on the right side, and check state of the Register Plugin option.

Note that the state of this option could affect where and how SQL Assistant reads its configuration settings.
Thu Aug 07, 2008 11:59 am View user's profile Send private message
seth.rothman



Joined: 29 Jan 2008
Posts: 42
Country: United States

Post Reply with quote
It is registered as an add-in.
Thu Aug 07, 2008 12:42 pm View user's profile Send private message
seth.rothman



Joined: 29 Jan 2008
Posts: 42
Country: United States

Post Reply with quote
Is there anything else I can try to troubleshoot?
Fri Aug 08, 2008 10:19 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6485

Post Reply with quote
Try unchecking the "add-on" option and restarting SSMS. If that doesn't help, please verify settings in SQL Assistant options and make sure on the Code Formatting tab for T-SQL you have "Convert keywords to" option set to "Upper case."

By the way, are you using the same Windows login as before? Did you install recently any system upgrades, service packs, etc... that could affect your Windows user account settings and their location?
Are you running Vista or XP?
Fri Aug 08, 2008 10:28 am View user's profile Send private message
seth.rothman



Joined: 29 Jan 2008
Posts: 42
Country: United States

Post Reply with quote
I found out what was wrong. The "Code Formatting Style" for SMSS was set to one that wasn't being used (i.e. unchecked). I'm not sure how I managed to do that but I must've done it somehow. Apologies for the wild goose chase.
Fri Aug 08, 2008 10:38 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6485

Post Reply with quote
Thanks for the update. At last, the problem has been solved.
Fri Aug 08, 2008 10:46 am View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.