SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
Job not running when 24x7 is running as servic

 
Reply to topic    SoftTree Technologies Forum Index » 24x7 Scheduler, Event Server, Automation Suite View previous topic
View next topic
Job not running when 24x7 is running as servic
Author Message
Pierre Dupuis



Joined: 22 Aug 2000
Posts: 85

Post Job not running when 24x7 is running as service Reply with quote


Since I upgrade from your last version 3.4.2,
Job do not run when 24x7 is runnung as a service.
Job run well when the gui is running.

The 24x7 sheduler service log on as a domain user.

Please could you help.

Fri Feb 21, 2003 3:58 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6500

Post Re: Job not running when 24x7 is running as servic Reply with quote

Some other people reported this problem in 3.4.2 and 3.4.1. We are working on a fix and will include into 3.4.3.Please for now either run 24x7 in non-service mode or rollback to 3.4.0 or earlier.

: Since I upgrade from your last version 3.4.2,
: Job do not run when 24x7 is runnung as a service.
: Job run well when the gui is running.

: The 24x7 sheduler service log on as a domain user.

: Please could you help.

Fri Feb 21, 2003 4:49 pm View user's profile Send private message
Pierre Dupuis



Joined: 22 Aug 2000
Posts: 85

Post Re: Job not running when 24x7 is running as servic Reply with quote

: Some other people reported this problem in 3.4.2 and 3.4.1. We are working on
: a fix and will include into 3.4.3.Please for now either run 24x7 in
: non-service mode or rollback to 3.4.0 or earlier.

Do you know when the new version wil be available?

Mon Feb 24, 2003 9:11 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6500

Post Re: Job not running when 24x7 is running as servic Reply with quote

Tomorrow

: Do you know when the new version wil be available?

Mon Feb 24, 2003 9:23 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6500

Post Re: Job not running when 24x7 is running as servic Reply with quote

First please check that in the schedule.log file you get "24x7 Scheduler [service] starting message..."
Please also check that you do not run the unregistered version.

Try to start the service manualy from the Control Panel's Services applet.

If some jobs do run but other don't please make sure not-running jobs don't reffer to networked files using mapped drive letters. Make sure they use UNC file names.

: Job do not run when 24x7 is runnung as a service.
: Job run well when the gui is running.

: The 24x7 sheduler service log on as a domain user.

: note: I am using your Last version 3.4.3.

: Please could you help.

Tue Mar 04, 2003 3:08 pm View user's profile Send private message
Pierre Dupuis



Joined: 22 Aug 2000
Posts: 85

Post Re: Job not running when 24x7 is running as servic Reply with quote

When I start the service, nothing is write in Schedule.log.
Same thing when I stop the service.

When I start the GUI version
I have "24x7 Scheduler starting..." message in Schedule.log.

: First please check that in the schedule.log file you get "24x7 Scheduler
: [service] starting message..."
: Please also check that you do not run the unregistered version.

: Try to start the service manualy from the Control Panel's Services applet.

: If some jobs do run but other don't please make sure not-running jobs don't
: reffer to networked files using mapped drive letters. Make sure they use
: UNC file names.

Tue Mar 04, 2003 3:43 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6500

Post Re: Job not running when 24x7 is running as servic Reply with quote

Do you have 24x7 installed in multiple places?
Is it installed on a network drive or locally?
When you manually start the service do you see 24x7.exe in the Task List?

Also check settings for the 24x7 service in the Control Panel's Services applet. Make sure it points to the correct 24x7srv.exe file.

: When I start the service, nothing is write in Schedule.log.
: Same thing when I stop the service.

: When I start the GUI version
: I have "24x7 Scheduler starting..." message in Schedule.log.

Tue Mar 04, 2003 4:09 pm View user's profile Send private message
Pierre Dupuis



Joined: 22 Aug 2000
Posts: 85

Post Re: Job not running when 24x7 is running as servic Reply with quote

We 24x7 install on 2 servers (v2 and v3).
This server is running 24x7 v3.4.3 installed locally.
I see 24x7.exe and 24x7srv.exe in task manager when I manually start the service.
24x7srv.exe points to C:\Program Files\24x7 Automation 3\24x7srv.exe

: Do you have 24x7 installed in multiple places?
: Is it installed on a network drive or locally?
: When you manually start the service do you see 24x7.exe in the Task List?

: Also check settings for the 24x7 service in the Control Panel's Services
: applet. Make sure it points to the correct 24x7srv.exe file.

Tue Mar 04, 2003 4:24 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6500

Post Re: Job not running when 24x7 is running as servic Reply with quote

Temporarily change service account to LocalSystem and check "Allow service to interact with Desktop" option. Start the service manually. Check if there will be any errors displayed on the screen and also if the 24x7 icon will appear in the system tray.

Check again the schedule.log file. It must have some new entries.

Please keep us posted.

: We 24x7 install on 2 servers (v2 and v3).
: This server is running 24x7 v3.4.3 installed locally.
: I see 24x7.exe and 24x7srv.exe in task manager when I manually start the
: service.
: 24x7srv.exe points to C:\Program Files\24x7 Automation 3\24x7srv.exe

Tue Mar 04, 2003 6:07 pm View user's profile Send private message
Pierre Dupuis



Joined: 22 Aug 2000
Posts: 85

Post Re: Job not running when 24x7 is running as servic Reply with quote

I changed the service account like you requested.
I have no error message. and I can see the system tray icon.

I also have an entry in schedule.log "24x7 service] 24x7 Scheduler starting..."

Should I reinstall 24x7?

: Temporarily change service account to LocalSystem and check "Allow
: service to interact with Desktop" option. Start the service manually.
: Check if there will be any errors displayed on the screen and also if the
: 24x7 icon will appear in the system tray.

: Check again the schedule.log file. It must have some new entries.

: Please keep us posted.

Wed Mar 05, 2003 9:18 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6500

Post Re: Job not running when 24x7 is running as servic Reply with quote

How the job is setup?
Does it have a notification action to be exected on job startup?
Does it use email functions?
Does it have "log" option disabled?

Why do you think the job does not run?

: I changed the service account like you requested.
: I have no error message. and I can see the system tray icon.

: I also have an entry in schedule.log "24x7 service] 24x7 Scheduler
: starting..."

: Should I reinstall 24x7?

Wed Mar 05, 2003 12:03 pm View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » 24x7 Scheduler, Event Server, Automation Suite All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.