SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
Debugging woes

 
Reply to topic    SoftTree Technologies Forum Index » 24x7 Scheduler, Event Server, Automation Suite View previous topic
View next topic
Debugging woes
Author Message
Steve Silberberg



Joined: 14 Aug 2002
Posts: 14

Post Debugging woes Reply with quote

Why is debugging so difficult on 24x7?

About half the time, hitting debug will start a job
and never even bring up a debugging screen. I can't
even begin to guess what's going on. The only reason
I know anything is going on at all is that I have
it send me mail on Start Event.

Some jobs it works great on. What could possibly be
the difference? I can't set breakpoints unless I'm
already debugging the job.

Furthermore, I can't seem to get trace to run. I put
it in Master mode and get the DOS trace screen, but
nothing ever shows up on it other than some impossible
to decipher memory allocation numbers.

Help!!!!!!

Mon Oct 28, 2002 11:18 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6499

Post Re: Debugging woes Reply with quote

Sounds as it hangs before hitting the main job script; most likely it hangs while executing the notification action that's why you don't get the debugger screen.

: Why is debugging so difficult on 24x7?

: About half the time, hitting debug will start a job
: and never even bring up a debugging screen. I can't
: even begin to guess what's going on. The only reason
: I know anything is going on at all is that I have
: it send me mail on Start Event.

: Some jobs it works great on. What could possibly be
: the difference? I can't set breakpoints unless I'm
: already debugging the job.

: Furthermore, I can't seem to get trace to run. I put
: it in Master mode and get the DOS trace screen, but
: nothing ever shows up on it other than some impossible
: to decipher memory allocation numbers.

: Help!!!!!!

Mon Oct 28, 2002 11:35 am View user's profile Send private message
Steve Silberberg



Joined: 14 Aug 2002
Posts: 14

Post Re: Debugging woes Reply with quote

: Sounds as it hangs before hitting the main job script; most likely it hangs
: while executing the notification action that's why you don't get the
: debugger screen.

Thanks! This is what's happening, but why? I finally
got something to work, but I had to disable the
script that runs on Start Event before it would allow
me to do anything. Since the debugger won't let
me debug the Event Script, what do I do? The first
statement in the script is a messagebox, but it never
gets there!

I can 'successfully' run the Start Event script
using a remote agent, but then a reference to a
file in 'c:' fails.

Please help.
fails

Mon Oct 28, 2002 3:35 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6499

Post Re: Debugging woes Reply with quote

Try using UNC file names as \\machine\share_name\path\file_name
UNC names will allow you to debug the job on both computers.

By the way the easiest way to debug notification events is to use LogAddMessageEx calls instead of MessageBox calls.

: Thanks! This is what's happening, but why? I finally
: got something to work, but I had to disable the
: script that runs on Start Event before it would allow
: me to do anything. Since the debugger won't let
: me debug the Event Script, what do I do? The first
: statement in the script is a messagebox, but it never
: gets there!

: I can 'successfully' run the Start Event script
: using a remote agent, but then a reference to a
: file in 'c:' fails.

: Please help.
: fails

Mon Oct 28, 2002 3:48 pm View user's profile Send private message
Steve Silberberg



Joined: 14 Aug 2002
Posts: 14

Post Re: Debugging woes Reply with quote

: By the way the easiest way to debug notification events is to use
: LogAddMessageEx calls instead of MessageBox calls.

I tried this, but the job still never hits the LogAddMessageEx
call, even though it's the first line in the event script.

Could running as master be a problem here?

: Try using UNC file names as \\machine\share_name\path\file_name
: UNC names will allow you to debug the job on both computers.

I had UNC names in there, but RunAndWait() complained.


Mon Oct 28, 2002 4:07 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6499

Post Re: Debugging woes Reply with quote

RunAndWait complained because you probably specified the file name exactly as \\machine... and so on

Either change the default special ASCII symbols escape character or or prefix every backslash with another backslash
Example (except from the script):
\\\\MY_PC\\C$\\data\\file.txt

I remember that some versions of 24x7 had problem with notification events of script types (could be 3.3.1 or 3.3.2). This problem is fixed in more recent versions. Please consider upgrading if you are running one of these.

: I tried this, but the job still never hits the LogAddMessageEx
: call, even though it's the first line in the event script.

: Could running as master be a problem here?

: I had UNC names in there, but RunAndWait() complained.

Mon Oct 28, 2002 4:18 pm View user's profile Send private message
Steve Silberberg



Joined: 14 Aug 2002
Posts: 14

Post Re: Debugging woes Reply with quote

: RunAndWait complained because you probably specified the file name exactly as
: \\machine... and so on

Actually, I had it delimited properly. Maybe it's
got to do with version too?

: I remember that some versions of 24x7 had problem with notification events of
: script types (could be 3.3.1 or 3.3.2). This problem is fixed in more
: recent versions. Please consider upgrading if you are running one of
: these.

I think you solved the problem!!!
I bought a version yesterday (!) and it was v 3.3.0.
I don't know why SoftTreeTech or its distributors is
making this available to new purchasers, but it would
seem like a really bad business decision.

Do you know how I can actually get 3.3.5 or 3.3.7 given
that the transaction has already been paid for?

Mon Oct 28, 2002 4:56 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6499

Post Re: Debugging woes Reply with quote

http://www.24x7automation.com/download/247setup.exe

A free download link is also available on the main site.

: Actually, I had it delimited properly. Maybe it's
: got to do with version too?

: I think you solved the problem!!!
: I bought a version yesterday (!) and it was v 3.3.0.
: I don't know why SoftTreeTech or its distributors is
: making this available to new purchasers, but it would
: seem like a really bad business decision.

: Do you know how I can actually get 3.3.5 or 3.3.7 given
: that the transaction has already been paid for?

Mon Oct 28, 2002 5:03 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6499

Post Re: Debugging woes Reply with quote

Then you either incorrectly specified file name or share name or perhaps you had no enough permissions to access the referenced file.

: Actually, I had it delimited properly. Maybe it's
: got to do with version too?

: I think you solved the problem!!!
: I bought a version yesterday (!) and it was v 3.3.0.
: I don't know why SoftTreeTech or its distributors is
: making this available to new purchasers, but it would
: seem like a really bad business decision.

: Do you know how I can actually get 3.3.5 or 3.3.7 given
: that the transaction has already been paid for?

Mon Oct 28, 2002 6:09 pm View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » 24x7 Scheduler, Event Server, Automation Suite All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.