SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
Invalid Page Fault

 
Reply to topic    SoftTree Technologies Forum Index » 24x7 Scheduler, Event Server, Automation Suite View previous topic
View next topic
Invalid Page Fault
Author Message
Reggie Laffond



Joined: 28 Sep 2000
Posts: 7

Post Invalid Page Fault Reply with quote

I am currently using trial version 2.3.2 of 24X7 Scheduler to determine if it will satisfy my company's needs. Generally it has been able to accomplish most of what we want but occasionally a dialog box is displayed which states that an Invalid Page Fault has been detected. The details are below. This happens when I attempt to SendMailWithAttachment. Anyone know why this happens?

24X7 caused an invalid page fault in
module EMSUIX32.DLL at 0157:6f672e55.
Registers:
EAX=00445120 CS=0157 EIP=6f672e55 EFLGS=00010202
EBX=00000000 SS=015f ESP=0066e794 EBP=0066e7cc
ECX=004450fc DS=015f ESI=00000000 FS=443f
EDX=ffffffff ES=015f EDI=0066e7c8 GS=0000
Bytes at CS:EIP:
8b 16 85 d2 75 08 83 c6 04 43 3b d8 72 f2 8b 2a
Stack dump:
0066e7cc 004450e0 004450fc 00000000
6f679384 0066e7c8 0066e7c0 0066e7c4
00000000 00444ffc 6f620000 07230000
6f678b0d ffffffff 0066e9c4 6f679478

Thu Sep 28, 2000 9:28 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6508

Post Re: Invalid Page Fault Reply with quote

Which application owns EMSUIX32.DLL? This is not a part of 24x7 Scheduler

Can you post here your code that does SendMailWithAttachment?

: I am currently using trial version 2.3.2 of 24X7 Scheduler to determine if it
: will satisfy my company's needs. Generally it has been able to accomplish
: most of what we want but occasionally a dialog box is displayed which
: states that an Invalid Page Fault has been detected. The details are
: below. This happens when I attempt to SendMailWithAttachment. Anyone know
: why this happens?

: 24X7 caused an invalid page fault in
: module EMSUIX32.DLL at 0157:6f672e55.
: Registers: EAX=00445120 CS=0157 EIP=6f672e55 EFLGS=00010202
: EBX=00000000 SS=015f ESP=0066e794 EBP=0066e7cc
: ECX=004450fc DS=015f ESI=00000000 FS=443f
: EDX=ffffffff ES=015f EDI=0066e7c8 GS=0000
: Bytes at CS:EIP: 8b 16 85 d2 75 08 83 c6 04 43 3b d8 72 f2 8b 2a
: Stack dump: 0066e7cc 004450e0 004450fc 00000000
: 6f679384 0066e7c8 0066e7c0 0066e7c4
: 00000000 00444ffc 6f620000 07230000
: 6f678b0d ffffffff 0066e9c4 6f679478

Thu Sep 28, 2000 10:34 am View user's profile Send private message
Reggie Laffond



Joined: 28 Sep 2000
Posts: 7

Post Re: Invalid Page Fault Reply with quote

I'm not sure who owns EMSUIX32.DLL but it's possible that it is Microsoft Outlook which is my mail client. If it is mandatory that we determine who owns th DLL I will research it further.

The code which causes the error is below.

MailSendWithAttachment( "WMC Mail", "", "svhprod.wmcapps@tenethealth.com", "UIS Job Failed", "No UISBack.txt in h:\olie\original directory", "h:\olie\log\UISback.log" )

: Which application owns EMSUIX32.DLL? This is not a part of 24x7 Scheduler

: Can you post here your code that does SendMailWithAttachment?

I am currently using trial version 2.3.2 of 24X7 Scheduler to determine if it will satisfy my company's needs. Generally it has been able to accomplish most of what we want but occasionally a dialog box is displayed which states that an Invalid Page Fault has been detected. The details are below. This happens when I attempt to SendMailWithAttachment. Anyone know why this happens?

24X7 caused an invalid page fault in
module EMSUIX32.DLL at 0157:6f672e55.
Registers:
EAX=00445120 CS=0157 EIP=6f672e55 EFLGS=00010202
EBX=00000000 SS=015f ESP=0066e794 EBP=0066e7cc
ECX=004450fc DS=015f ESI=00000000 FS=443f
EDX=ffffffff ES=015f EDI=0066e7c8 GS=0000
Bytes at CS:EIP:
8b 16 85 d2 75 08 83 c6 04 43 3b d8 72 f2 8b 2a
Stack dump:
0066e7cc 004450e0 004450fc 00000000
6f679384 0066e7c8 0066e7c0 0066e7c4
00000000 00444ffc 6f620000 07230000
6f678b0d ffffffff 0066e9c4 6f679478


Thu Sep 28, 2000 10:51 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6508

Post Re: Invalid Page Fault Reply with quote

Do you need a password when you open Outlook? If yes, you should specifiy it as a second parameter in the MailSendWithAttachment

Does MailSend cause an Invalid Page Fault or it is just MailSendWithAttachment that leads to it?

: I'm not sure who owns EMSUIX32.DLL but it's possible that it is Microsoft
: Outlook which is my mail client. If it is mandatory that we determine who
: owns th DLL I will research it further.

: The code which causes the error is below.

: MailSendWithAttachment( "WMC Mail", "",
: "svhprod.wmcapps@tenethealth.com", "UIS Job Failed",
: "No UISBack.txt in h:\olie\original directory",
: "h:\olie\log\UISback.log" )

: I am currently using trial version 2.3.2 of 24X7 Scheduler to determine if it
: will satisfy my company's needs. Generally it has been able to accomplish
: most of what we want but occasionally a dialog box is displayed which
: states that an Invalid Page Fault has been detected. The details are
: below. This happens when I attempt to SendMailWithAttachment. Anyone know
: why this happens?

: 24X7 caused an invalid page fault in
: module EMSUIX32.DLL at 0157:6f672e55.
: Registers: EAX=00445120 CS=0157 EIP=6f672e55 EFLGS=00010202
: EBX=00000000 SS=015f ESP=0066e794 EBP=0066e7cc
: ECX=004450fc DS=015f ESI=00000000 FS=443f
: EDX=ffffffff ES=015f EDI=0066e7c8 GS=0000
: Bytes at CS:EIP: 8b 16 85 d2 75 08 83 c6 04 43 3b d8 72 f2 8b 2a
: Stack dump: 0066e7cc 004450e0 004450fc 00000000
: 6f679384 0066e7c8 0066e7c0 0066e7c4
: 00000000 00444ffc 6f620000 07230000
: 6f678b0d ffffffff 0066e9c4 6f679478

Thu Sep 28, 2000 11:21 am View user's profile Send private message
Reggie Laffond



Joined: 28 Sep 2000
Posts: 7

Post Re: Invalid Page Fault Reply with quote

I have an Outlook session on the task bar when I issue the MailSendWithAttachment command so a password is not necessary. I didn't mention earlier but the E-mail always gets to the intended recipient. It's just the "Invalid Page Fault" I'm trying to correct.

After more analysis I have found I can duplicate the problem. I always get the error the next time I run the job after I have been in the Script Editor. After I get the error once I don't get it again until I go into the script editor and come out and run the job again. Any ideas how to prevent this?

: Do you need a password when you open Outlook? If yes, you should specifiy it
: as a second parameter in the MailSendWithAttachment

: Does MailSend cause an Invalid Page Fault or it is just
: MailSendWithAttachment that leads to it?

Thu Sep 28, 2000 12:37 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6508

Post Re: Invalid Page Fault Reply with quote

Does it happen if you don't change anything in the editor, just open then close it without changing anything?
Does the disk icon start blinking on the status bar after you close the editor?
Are there other jobs running in the background while you are in the editor?

: I have an Outlook session on the task bar when I issue the
: MailSendWithAttachment command so a password is not necessary. I didn't
: mention earlier but the E-mail always gets to the intended recipient. It's
: just the "Invalid Page Fault" I'm trying to correct.

: After more analysis I have found I can duplicate the problem. I always get
: the error the next time I run the job after I have been in the Script
: Editor. After I get the error once I don't get it again until I go into
: the script editor and come out and run the job again. Any ideas how to
: prevent this?

Thu Sep 28, 2000 2:06 pm View user's profile Send private message
Reggie Laffond



Joined: 28 Sep 2000
Posts: 7

Post Re: Invalid Page Fault Reply with quote

It doesn't matter if I make a change or not. Just opening the editor causes the problem.
The disk icon does blink after closing the editor. It doesn't matter whether I save or not.
The only other job running is Microsoft Outlook,

: Does it happen if you don't change anything in the editor, just open then
: close it without changing anything?
: Does the disk icon start blinking on the status bar after you close the
: editor?
: Are there other jobs running in the background while you are in the editor?

Fri Sep 29, 2000 11:02 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6508

Post Re: Invalid Page Fault Reply with quote

The icon shouldn't blink if you didn't make any changes, unless you first open the Job Properties Wizard, and after you exit the Editor you click on the Finish button which cause the job state to be marked as "modified". As a result of that you can see the blinking icon. How much free resources do you have when the Wizard is opened?

: It doesn't matter if I make a change or not. Just opening the editor causes
: the problem.
: The disk icon does blink after closing the editor. It doesn't matter whether
: I save or not.
: The only other job running is Microsoft Outlook,

Fri Sep 29, 2000 2:05 pm View user's profile Send private message
Reggie Laffond



Joined: 28 Sep 2000
Posts: 7

Post Re: Invalid Page Fault Reply with quote

The icon behaves exactly as you stated. It blinks if I open the Job Properties Wizard and click finish whether or not I open the script editor.

The free resources are at 96%.

Based on more research I have found that opening the Script Editor is causing the problem. Whether I use the Job Properties Wizard or the save button has no effect. Opening the Script Editor causes the error whether I click the "Edit" button in the Job Properties Wizard or use pull-down menus "File" - "Edit Script" or press CTRL-E. And it doesn't matter if I make a change or not.

: The icon shouldn't blink if you didn't make any changes, unless you first
: open the Job Properties Wizard, and after you exit the Editor you click on
: the Finish button which cause the job state to be marked as
: "modified". As a result of that you can see the blinking icon.
: How much free resources do you have when the Wizard is opened?

Fri Sep 29, 2000 3:19 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6508

Post Re: Invalid Page Fault Reply with quote

There is nothing that links the Editor and MS Outlook, not even shared Windows DLLs.
Try reinstalling 24x7 Scheduler using the most recent version.

: The icon behaves exactly as you stated. It blinks if I open the Job
: Properties Wizard and click finish whether or not I open the script
: editor.

: The free resources are at 96%.

: Based on more research I have found that opening the Script Editor is causing
: the problem. Whether I use the Job Properties Wizard or the save button
: has no effect. Opening the Script Editor causes the error whether I click
: the "Edit" button in the Job Properties Wizard or use pull-down
: menus "File" - "Edit Script" or press CTRL-E. And it
: doesn't matter if I make a change or not.

Fri Sep 29, 2000 4:40 pm View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » 24x7 Scheduler, Event Server, Automation Suite All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.