SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
SQL Assistant blank popup in UltraEdit

 
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant View previous topic
View next topic
SQL Assistant blank popup in UltraEdit
Author Message
mksql



Joined: 29 Dec 2006
Posts: 19
Country: United States

Post SQL Assistant blank popup in UltraEdit Reply with quote
As a test, I hit ^space while in UltraEdit 12.20 (my usual editor), and a blank popup appeared at the cursor, the same size as the popup seen in ISQLW. No connection dialog is displayed as in Notepad.
Fri Dec 29, 2006 5:08 pm View user's profile Send private message Yahoo Messenger
mksql



Joined: 29 Dec 2006
Posts: 19
Country: United States

Post Reply with quote
On a second attempt after closing, and restarting UltraEdit, all SQL Assistant functions appear to operate.

Very nice!
Fri Dec 29, 2006 5:17 pm View user's profile Send private message Yahoo Messenger
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6502

Post Reply with quote
Did you get an empty popup immediately after registering UtlraEdit as a new editor target?

Does it work now or you still have to stop and restart it twice every time?
Sat Dec 30, 2006 1:07 am View user's profile Send private message
mksql



Joined: 29 Dec 2006
Posts: 19
Country: United States

Post Reply with quote
It appears that the initial blank popup is coming from UltraEdit's AutoComplete, not SQL Assistant. It displays the list of keywords available for the current syntax highlight language, and in my test case, since there was no language selected, the window was blank. If I am in a file UltraEdit recognizes as an SQL file, the popup contains the UltraEdit keyword list.

To get SQL Assistant to work, it appears optional to unbind Ctrl+Space in Ultraedit (I never used it anyway), and/or trigger the SQL Assistant connect dialog via a SQL keyword. This way the two components are not attempting to bind to the same key sequence. Once complete, SQL Assistant seems to work well.

Since UltraEdit is my primary editor, I will be spending more time with it in combination with SQL Assistant.
Tue Jan 02, 2007 9:23 am View user's profile Send private message Yahoo Messenger
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6502

Post Reply with quote
If you wish, you can choose a different hot key in SQL Assistant. Double-click on the SQL Assistant icon in the system tray, on the Options tab click Show SQL Assistant field, this is where it currently displays Ctrl+Space, and then press a new hotkey. Click OK button to apply changes. This way you should be able to resolve the Ctrl+Space hotkey sharing issue.
Tue Jan 02, 2007 9:40 am View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.