SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
Job not running on schedule (First Monday of each month)

 
Reply to topic    SoftTree Technologies Forum Index » 24x7 Scheduler, Event Server, Automation Suite View previous topic
View next topic
Job not running on schedule (First Monday of each month)
Author Message
AllenV



Joined: 12 Jul 2019
Posts: 10
Country: United States

Post Job not running on schedule (First Monday of each month) Reply with quote
This issue has plagued us since earlier versions, but since we just upgraded we thought it would be resolved. A job was supposed to run on 11/4 (first Monday of Nov), but it never ran. Anyone know of any issues that this type of schedule has and how to resolve? Thanks.
Thu Nov 14, 2019 6:19 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6983

Post Reply with quote
How does it look in the forecast report?
Thu Nov 14, 2019 6:27 pm View user's profile Send private message
AllenV



Joined: 12 Jul 2019
Posts: 10
Country: United States

Post Reply with quote
I only see a 7-day Job forecast report and this job isn't scheduled to run again until December 2, 2019 so it doesn't show up in the report.
Fri Nov 15, 2019 11:41 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6983

Post Reply with quote
May I ask you to create a test job with similar settings but choose a schedule that would make it appear in the 7-day forecast? My objective is to check if a monthly job with the same kind of settings, the same calendar assigned is visible in the forecast and so is expected to run. If it's missing in the forecast, then we may need to investigate global settings or calendar related settings rather then the job itself.
Mon Nov 18, 2019 11:21 am View user's profile Send private message
AllenV



Joined: 12 Jul 2019
Posts: 10
Country: United States

Post Reply with quote
Creating a similar job does show it is in the 7-day forecast report. So a little more background. In the old version, it would sometimes run. The individual managing the job would have a reminder on their calendar set to check whether the job ran successfully or not. If it did, great. If it didn't, then they would run the job manually. I'm thinking it could be running into the same issue with this new version.
Mon Nov 18, 2019 12:00 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6983

Post Reply with quote
Are there other jobs scheduled to start at the same time and in the same queue?

Are the dates when it didn't run align with weekends?
Mon Nov 18, 2019 12:37 pm View user's profile Send private message
AllenV



Joined: 12 Jul 2019
Posts: 10
Country: United States

Post Reply with quote
The job is running under its own separate queue. There is another job that runs at the same time, but it uses a different queue. The weekend shouldn't be a problem because it is using the Monthly; Execute on the First Monday schedule so it should never fall on a weekend.
Mon Nov 18, 2019 1:05 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6983

Post Reply with quote
Thanks. Do you have a log of days when it didn't start automatically?
What is the actual start time for the job?
Is your server configured to synchronize its clock? How often?
Tue Nov 19, 2019 12:37 pm View user's profile Send private message
AllenV



Joined: 12 Jul 2019
Posts: 10
Country: United States

Post Reply with quote
This year it appears it did not run on 3 occasions according to the individual who manages this job.
January 7, 2019
February 4, 2019
November 4, 2019

The job starts at 6:30am on the First Monday of each month

The server is configured to sync clocks. They stay within 1 second of the time server.
Wed Nov 20, 2019 5:30 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6983

Post Reply with quote
How often is the clock checked/synced? Could that occur at 6:30am?
Wed Nov 20, 2019 6:37 pm View user's profile Send private message
AllenV



Joined: 12 Jul 2019
Posts: 10
Country: United States

Post Reply with quote
I suppose it is possible. I found a SpecialPollInterval with a value of 3600 in the registry HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\w32Time\TimeProviders\NtpClient​

So it would appear it synchronizes every hour and that probably changes depending on when the server was last rebooted.
Thu Nov 21, 2019 11:43 am View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » 24x7 Scheduler, Event Server, Automation Suite All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.