SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
[11.0.6 Beta] - Slow tab operations

 
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant View previous topic
View next topic
[11.0.6 Beta] - Slow tab operations
Author Message
gemisigo



Joined: 11 Mar 2010
Posts: 1525
Country: Hungary

Post [11.0.6 Beta] - Slow tab operations Reply with quote
Sometimes opening a new tab or closing an existing one is extremely slow. It takes ~10 seconds from the moment the New icon is clicked (or Ctrl+N pressed) until the SQL Assistant - Connect to... dialog pops up. It also takes considerably more time than I'd anticipate closing an existing tab. Until the Connect to dialog is open or the tab closed the SQL Editor is frozen. Cannot reliably reproduce, but happens quite frequently.

Check this short video here.
Thu Jul 11, 2019 8:43 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6845

Post Reply with quote
We are looking into this issue.
Thu Jul 11, 2019 11:18 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6845

Post Reply with quote
Can you please check if you have any connections with auto-connection option set. If there is a connection like that and it's invalid - it may try to connect and after 10 seconds timeout show the Connect dialog. That's why it takes a while. If you find such connections, please clear that option.
Thu Jul 11, 2019 1:05 pm View user's profile Send private message
gemisigo



Joined: 11 Mar 2010
Posts: 1525
Country: Hungary

Post Reply with quote
I had. But it wasn't invalid. It seems something causes this problem with or without the connection set to auto connect being invalid. It also doesn't explain why it happens when closing a tab. That doesn't pop the Connect dialog and certainly shouldn't try to connect to anything in the background, should it?

Furthermore, removing the check from the connection dialog here does not work:







After reopening the Connect dialog the checkbox is set again. I had to open SA Options and set Auto Connection to None in Targets > SQL Assistant Code Editor > Advanced to make it gone.





I've set auto connect to the connection I intended to connect to, connected, and then clicked New tab. The connection was automatically made. After ~10 seconds. Check this (not so) short video here.


I've run into a funny bug while trying to capture a screenshot:



Fri Jul 12, 2019 5:53 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6845

Post Reply with quote
Most of the issues described in this message thread are expected to be fixed in the next beta version build, tentatively over the weekend.
Fri Jul 12, 2019 8:59 am View user's profile Send private message
gemisigo



Joined: 11 Mar 2010
Posts: 1525
Country: Hungary

Post Reply with quote
Thank you very much, eagerly awaiting the update.
Fri Jul 12, 2019 9:02 am View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.