SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
SA 10 Bata Issue - Show DDL does not work

 
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant View previous topic
View next topic
SA 10 Bata Issue - Show DDL does not work
Author Message
madgo



Joined: 22 Aug 2018
Posts: 13
Country: United States

Post SA 10 Bata Issue - Show DDL does not work Reply with quote
When you select a table name (in Visual Studio 2014) and right click and select Show Object DDL from SA context menu it does nothing.
Wed Aug 22, 2018 12:37 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6926

Post Reply with quote
Hi. Where do you select that table name? In the editor within the text, or in the Database Explorer? If in the Database Explorer, do you have any editors open at that time?
May I ask to to a attach a small screenshot demonstrating where you select a table, and nothing happens for Show DDL? It's kind of important foru s to understand the context.
Wed Aug 22, 2018 12:48 pm View user's profile Send private message
madgo



Joined: 22 Aug 2018
Posts: 13
Country: United States

Post Reply with quote
In the editor with in the text. I use this a lot. Here is the screenshot.

Wed Aug 22, 2018 3:05 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6926

Post Reply with quote
The screenshot is for SQL Server Management Studio. Is that what you meant when you referred to Visual Studio?
What happens when you hold down Ctrl key and mouse over the table name? Do you see an yellowish balloon with table columns and some links at the top? If yes, when you click the Code link in the right-top corner, does it show the DDL of the table in the lower part of the screen?
Wed Aug 22, 2018 3:11 pm View user's profile Send private message
madgo



Joined: 22 Aug 2018
Posts: 13
Country: United States

Post Reply with quote
Sorry my bad. Yes it's SSMS 2014. Nope. nothing happens with ctrl+mouse move
Wed Aug 22, 2018 3:29 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6926

Post Reply with quote
I think it's an issue with add-on installation.

Please close SSMS
Double-click SQL Assistant icon in the system tray
Click Target tab, then MS Management Studio
Expand Advanced section on the right
Set Register SQL Assistant add-on option to No, click Apply button
Set Register SQL Assistant add-on option to Yes, click Apply button again
Restart SSMS

Does it work after that?

If still not, does it work if you start SSMS in Run as Administrator mode?
Wed Aug 22, 2018 4:17 pm View user's profile Send private message
madgo



Joined: 22 Aug 2018
Posts: 13
Country: United States

Post Reply with quote
No luck with both the solutions.
Wed Aug 22, 2018 5:22 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6926

Post Reply with quote
Does the same work in other applications, for example in SQL Assistant's SQL Editor?
Wed Aug 22, 2018 6:32 pm View user's profile Send private message
madgo



Joined: 22 Aug 2018
Posts: 13
Country: United States

Post Reply with quote
it works in SA's SQL Editor
Thu Aug 23, 2018 10:58 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6926

Post Reply with quote
Please let me know the complete version number for your SSMS.

Do you have other versions of SSMS to try with? I wonder if this issue is specific to your version of SSMS.
Thu Aug 23, 2018 4:21 pm View user's profile Send private message
madgo



Joined: 22 Aug 2018
Posts: 13
Country: United States

Post Reply with quote
it happens SSMS 2014 (12.0.5207.0). It does not happen latest version of SSMS 17.8.1 (14.0.17277.0)
Fri Aug 24, 2018 5:24 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6926

Post Reply with quote
Thank you very much for the additional information. It looks like there is a compatibility issue with that particular version of SSMS 2014. I'm going to log this in our issue tracking system for further analysis.
Sat Aug 25, 2018 3:49 am View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.