SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
[9.2.349] - Document Manager doesn't always save revisions

 
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant View previous topic
View next topic
[9.2.349] - Document Manager doesn't always save revisions
Author Message
Mindflux



Joined: 25 May 2013
Posts: 616
Country: United States

Post [9.2.349] - Document Manager doesn't always save revisions Reply with quote
I keep coming across this in various forms:

Today I'm editing a stored procedure. I wanted to compare my current editor window to whatever the document manager may have saved.. but I can't find any revisions saved in document manager.

I close and re-open SQL Editor and try again thinking it's a hiccup. Same result.


If I hit Ctrl-0 after waiting 15 minutes after making a change, nothing shows up in any of the document manager filters. Usually "All Documents" show a document in bold (maybe current document tab?) but the "Current Document" and "Currently Opened" tabs are completely blank.. nothing. Then, if I decide to close SQL editor and get the save prompt and press CANCEL and immediately go back and hit ctrl-0, suddenly I have a bolded document in "All Documents" and they also show up in "Current Document" as well as "Currently Opened".. BUT I don't have the revision I started with prior to making my change (in this case, a comment to track if document manager is doing ok or not).

Then if I remove the comment, hit Ctrl-0 and check "HEAD" against Revision 1 I can see my changes in revision 1 versus the 'head file'. But none of this happens unless I somehow invoke the "Save Documents" dialog.

Shouldn't this be remembering changes I made in the editor tab throughout my coding session as well? Isn't that the point of the 15 minute backup interval is for?
Wed Aug 16, 2017 3:45 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6515

Post Reply with quote
Your description of what you expect from the revisions is correct. But why it doesn't work as expected is unclear.

Do you see multiple revisions saved for any recently modified files?
How many files do you currently have in the History subfolder?
Wed Aug 16, 2017 6:39 pm View user's profile Send private message
Mindflux



Joined: 25 May 2013
Posts: 616
Country: United States

Post Reply with quote
I do see some files, mostly with 1 revision(mostly all called query1.sql or something like that.. whatever the default name is). . I see a few with more but they're actual scripts I've saved and revised versus stuff I write ad hoc and may only use for a day or two.

I would say most of those are "forced" into document manager by closing out the editor to get that save dialog (even if I answer no so it doesn't save to a specific file name)

I'll have to check how many files are in the history subfolder tomorrow morning.
Wed Aug 16, 2017 6:50 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6515

Post Reply with quote
Could you also please check that %APPDATA%\SQL Assistant\9.2\saDocMng.xml file is not corrupted? Try to open it in a web browser. If that file is corrupted, your browser should show an error message.
Wed Aug 16, 2017 8:24 pm View user's profile Send private message
Mindflux



Joined: 25 May 2013
Posts: 616
Country: United States

Post Reply with quote
saDocMng.xml opens fine in chrome.

History directory contains 230 items.
Thu Aug 17, 2017 8:58 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6515

Post Reply with quote
Thank you. I'm afraid this goes beyond my knowledge. Let me try to get some help here.
Thu Aug 17, 2017 9:07 am View user's profile Send private message
Mindflux



Joined: 25 May 2013
Posts: 616
Country: United States

Post Reply with quote
Ok so I turned the auto save down to 3 minutes from 15


I wrote out a new query, commented in it that I created it at 8:09AM. 8:12 has come and gone and no autosave happened.

Oddly, the saDocMng.xml does have an 8:09 timestamp on it, though but that may be about the time I launched SQL Editor this morning as well.
Thu Aug 17, 2017 9:13 am View user's profile Send private message
Mindflux



Joined: 25 May 2013
Posts: 616
Country: United States

Post Reply with quote
I renamed saDocMng.xml and let it create a new one, still no document history being created.
Thu Aug 17, 2017 9:18 am View user's profile Send private message
Mindflux



Joined: 25 May 2013
Posts: 616
Country: United States

Post Reply with quote
Relaunched SQL Editor after the saDocMgr.xml rename and now I am getting saves, but changes to my document are not getting revision stamps.


They all end up in Revision 1

*edit: now I have a Revision 2.

Waiting to see if Revision 3 pops up after another change.


*edit 2: It does appear to be doing better now. I'm up to 3 revisions.

Perhaps the saDocMgr.xml was still corrupt in some way?
Thu Aug 17, 2017 9:23 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6515

Post Reply with quote
You may need to restart not just the editor but all other development tools and the systray app too because this file is shared across all of them.
Thu Aug 17, 2017 9:35 am View user's profile Send private message
Mindflux



Joined: 25 May 2013
Posts: 616
Country: United States

Post Reply with quote
Well in any case, it's acting much better. I opened the SPROC I was having problems with yesterday that prompted me to start this topic and it made an initial autosave pretty quickly. Going to see if I get a revision in a bit.
Thu Aug 17, 2017 9:38 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6515

Post Reply with quote
Would you please send a copy of your old file to support so that we can analyze it for errors? The objective is to identify the root cause and prevent recurrences of this issue
Thu Aug 17, 2017 10:26 am View user's profile Send private message
Mindflux



Joined: 25 May 2013
Posts: 616
Country: United States

Post Reply with quote
SysOp wrote:
Would you please send a copy of your old file to support so that we can analyze it for errors? The objective is to identify the root cause and prevent recurrences of this issue


Sure, I just sent it.

I ran the XML through a parser app online and it didn't bark at me about malformed XML or anything, so I hope your team can identify the cause.
Thu Aug 17, 2017 10:29 am View user's profile Send private message
Mindflux



Joined: 25 May 2013
Posts: 616
Country: United States

Post Reply with quote
Hrmm there's definitely something hinky in there.

If you open a file out of document manager, it'll duplicate the data in document manager as well:

https://i.imgur.com/snE7DVL.png

It eventually cleans itself up and removes one of the duplicates but I can't help but wonder if this is part of the problem?
Thu Aug 17, 2017 11:34 am View user's profile Send private message
Mindflux



Joined: 25 May 2013
Posts: 616
Country: United States

Post Reply with quote
I hit this again. I can't say 100% for certain, but it had been working fine up until yesterday when I had SQL Editor open and I launched SSMS to check something else out.
Fri Oct 06, 2017 11:53 am View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.