SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
[SA 9.1.261 Pro] - Active tab after applying changes

 
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant View previous topic
View next topic
[SA 9.1.261 Pro] - Active tab after applying changes
Author Message
gemisigo



Joined: 11 Mar 2010
Posts: 1390

Post [SA 9.1.261 Pro] - Active tab after applying changes Reply with quote
I've experienced a very strange and bothering behavior after applying changes in SA Options when SE is open with multiple tabs. Whenever I change some setting and click Apply button the SE Window flickers for a very short time (few ms). I guess the connections are dropped and reestablished as SE goes through the open tabs and their connections but that's not that annoying. Earlier versions left the active tab active (I mean the currently selected tab did not change after applying the changes and restoring connections). The last few updates do otherwise. The flicker and connection reestablishment is still there but the active tab has changed. The tab that was active when the Apply button was clicked previously (ie. not the last click on it) will become the active tab.
Now this might not be the clearest explanation, so I'll try to describe it.

#1 Open SE and restore the last tabs that were open when it was closed. Let's say you have SE with 5 open tabs, the 5th being the active.
#2 Open SA Option, make some changes and click Apply button. Flicker, re-connections, and suddenly it's the 1st tab that is active (remember, the 5th was active when the button was clicked).
#3 Change again, Apply again with this 1st tab active and there you go, the active tab is the 5th one (remember, the 1st was active when the button was clicked).
#4 Select the 2nd tab, change settings in SA Options, Apply and now the 1st is the active again.
#5 Select whichever tab, change, Apply, and you'll end up with the 2nd tab active.
#6 rinse and repeat.
Fri Mar 10, 2017 9:52 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6484

Post Reply with quote
Thank you for reporting this issue. I have logged it in our issue tracker.
Fri Mar 10, 2017 10:31 am View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.