SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
[SA 9.0.176 Pro] - Delimiters vs Prefixes

 
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant View previous topic
View next topic
[SA 9.0.176 Pro] - Delimiters vs Prefixes
Author Message
gemisigo



Joined: 11 Mar 2010
Posts: 1390

Post [SA 9.0.176 Pro] - Delimiters vs Prefixes Reply with quote
Ignore Name Prefixes doesn't work properly when Always Add Delimiters is set to Always add brackets [ ]. I suppose it's because after adding delimiters '[' is considered part of the name. Selecting from the popup the view named v_nyomvonal_tetelek_insert in schema xform became
Code:

[xform].[v_nyomvonal_tetelek_insert] AS vnti

even though Ignore Name Prefixes had 'v_' to ignore. After adding '[v_' to the list, the code turned into
Code:

[xform].[v_nyomvonal_tetelek_insert] AS nti
as expected.

I haven't checked but I guess it affects other types of delimiters as well.
Sun Oct 30, 2016 8:54 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6485

Post Reply with quote
Unfortunately it seems to affect all delimiters. I can reproduce this issue too. It looks like the Always Add Delimiters options cannot be used along Ignore Name Prefixes.
I'm going to raise this issue and ask if that can be fixed.
Tue Nov 01, 2016 8:17 am View user's profile Send private message
gemisigo



Joined: 11 Mar 2010
Posts: 1390

Post Reply with quote
Thank you very much. Meanwhile, I'm going to add delimited versions of prefixes. That should work until there's a fix.
Tue Nov 01, 2016 3:56 pm View user's profile Send private message
gemisigo



Joined: 11 Mar 2010
Posts: 1390

Post Reply with quote
One more issue with adding delimiters: setting that option to Always add brackets [ ] will add those delimiters to variable names too when selecting a stored procedure from popup for EXECUTE, ending with something like:
Code:

EXECUTE [logs].[usp_bekeres_logolas]
        [@ip_v4] = NULL
       ,[@ip_v6] = NULL
       ,[@debug] = NULL   

Parsing such statements will fail because of the syntax error. Selecting variables from popup is unaffected.
Mon Nov 07, 2016 11:20 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6485

Post Reply with quote
Thank you very much. I'm logging this issue too. Hope it can be fixed quickly.
Mon Nov 07, 2016 11:38 am View user's profile Send private message
gemisigo



Joined: 11 Mar 2010
Posts: 1390

Post Reply with quote
Adding delimiters to parameter variable names for a stored procedure is no longer an issue. Ignoring name prefixes with added delimiters still is.

Could you post a short list of intended bugfixes so that we don't spam the forum re-reporting issues that are known as not fixed yet?
Mon Nov 21, 2016 5:51 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6485

Post Reply with quote
Quote:
Could you post a short list of intended bugfixes so that we don't spam the forum re-reporting issues that are known as not fixed yet?


Certainly. We will post them ASAP.


Quote:
Ignoring name prefixes with added delimiters still is

Prefixes with delimiters aren't currently supported it seems. No changes in the release notes for this and previous internal builds refer to that one.
Mon Nov 21, 2016 3:08 pm View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.