SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
6.2 Crash Visual Studio & Freezes Notepad++

 
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant View previous topic
View next topic
6.2 Crash Visual Studio & Freezes Notepad++
Author Message
benpage



Joined: 10 Aug 2011
Posts: 6
Country: United States

Post 6.2 Crash Visual Studio & Freezes Notepad++ Reply with quote
I'm on Windows 7 x64 and Visual Studio 2010 SP1. UAC is turned off and my user is an Administrator. SQL Assist was installed using the Professional option. I only want to use it with SSMS, not Visual Studio or anything else.

I let the SQL Assist update automatically, now Visual Studio starts with the error "The 'Visual Studio Component Model Host Package' package did not load correctly." It freezes, then crashes if I open a solution. If I start Notepad++, it uses a bunch of RAM and CPU, but the GUI never appears.

I tried un-checking Visual Studio and Notepad++ in the SQL Assist config. This allows Notepad++ to start, but Visual Studio does the exact same thing.

I uninstall SQL Assist everything works. When I reinstall, the same thing happens again.
Fri Jun 15, 2012 5:22 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 5216

Post Reply with quote
Is this is a new install or you have had previous version of SQL Assistant installed before this one?

Please check in the registry if you have
HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0\AddIns\SqlAssist.CSmsAddin
and
HKEY_CLASSES_ROOT\CLSID\{754CF073-05B2-4E97-880D-1D88D8D514BE}
keys, they could be from the old install, if you see them, delete them

Additionally, if you see files in %USERPROFILE%\Local Settings\Application Data\Microsoft\VisualStudio\10.0\Extensions\SoftTree Technologies\SqlAssist.vs\1.0\, delete them too.

That should fix the issue.
Fri Jun 15, 2012 5:36 pm View user's profile Send private message
benpage



Joined: 10 Aug 2011
Posts: 6
Country: United States

Post Reply with quote
Quote:
Is this is a new install or you have had previous version of SQL Assistant installed before this one?

Read my entire post.

Quote:
Please check in the registry if you have
HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0\AddIns\SqlAssist.CSmsAddin
and
HKEY_CLASSES_ROOT\CLSID\{754CF073-05B2-4E97-880D-1D88D8D514BE}
keys, they could be from the old install, if you see them, delete them

Additionally, if you see files in %USERPROFILE%\Local Settings\Application Data\Microsoft\VisualStudio\10.0\Extensions\SoftTree Technologies\SqlAssist.vs\1.0\, delete them too.

They don't exist.

Quote:
That should fix the issue.

It did not.
Fri Jun 15, 2012 5:44 pm View user's profile Send private message
benpage



Joined: 10 Aug 2011
Posts: 6
Country: United States

Post Reply with quote
I found a solution. I installed SQL Assist with the the Visual Studio Addin checked, even though I don't want it.

Your installer is telling Visual Studio to load the Addin, even if you don't choose to install it.
Fri Jun 15, 2012 5:47 pm View user's profile Send private message
Kato



Joined: 18 Jun 2012
Posts: 1
Country: Poland

Post Reply with quote
HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0\ExtensionManager\EnabledExtensions
u can find an entry with a lot of question mark: ??????????????????
If you remove it, all start working fine :)
Mon Jun 18, 2012 3:22 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 5216

Post Reply with quote
You are correct. That registry value entry is left from the previous version of SQL Assistant 6.1. It was used for the VS add-on registration, I 'm not sure why you have lots of question marks in there. Anyway, version 6.2 uses a different mechanism for loading the add-on and that registry value appears to be in the way. Thank you for reporting that.
Mon Jun 18, 2012 5:38 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 5216

Post Reply with quote
To be exact, the registry values that need to be deleted are

HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0\ExtensionManager\EnabledExtensions\SqlAssist.vs..3d117742-b761-4b83-86ce-ca2aa58a8660,1.0
and
HKEY_LOCAL_MACHINE\Software\Microsoft\VisualStudio\10.0\ExtensionManager\EnabledExtensions\SqlAssist.vs..3d117742-b761-4b83-86ce-ca2aa58a8660,1.0


Last edited by SysOp on Mon Aug 27, 2012 1:15 pm; edited 1 time in total
Mon Jun 18, 2012 5:43 pm View user's profile Send private message
deesnider



Joined: 27 Aug 2012
Posts: 1
Country: United States

Post Reply with quote
SysOp wrote:
You are correct. That registry value entry is left from the previous version of SQL Assistant 6.1. It was used for the VS add-on registration, I 'm not sure why you have lots of question marks in there. Anyway, version 6.2 uses a different mechanism for loading the add-on and that registry value appears to be in the way. Thank you for reporting that.

I think he meant that it puts in the path to the dll as the value but instead of the username it shows ??? like:

c:\documents and settings\???????????\LocalSettings\...

I saw this same problem with 6.2 (no previous installation of 6.1 as this is a new machine). I may have originally installed with VS integration, but then later tried to disable it due to these issues. That's when I found this post and saw the registry value above. Problem solved.
Mon Aug 27, 2012 12:49 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 5216

Post Reply with quote
Glad it worked for you.

PS. My 2 cents... the main reason for all these issues is Microsoft changing add-on registration methods and interfaces in every VS major version making life of other software publishers miserable.
Mon Aug 27, 2012 1:19 pm View user's profile Send private message
HLee



Joined: 30 Aug 2012
Posts: 1
Country: United States

Post Reply with quote
This particular issue just seriously cost our team. A few of us use SQL Assist and we installed the most recent version in the last few days, and this started causing Visual Studio (our main tool here) to crash with cryptic error messages about extensions. I was able to find this thread and fix my issue within an hour, but a co-worker spent hours trying to deal with this and even uninstalled and reinstalled VS, which takes quite some time.

This needs to be resolved directly in the application. Anyone with Visual Studio will not be able to use Visual Studio if they install 6.2.112, and their only recourse will be to contact STT. But that is only if they are able to deduce that the SQLAssist upgrade was what caused the issue.
Thu Aug 30, 2012 8:19 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 5216

Post Reply with quote
Very sorry for the caused inconvenience.

SQL Assistant version 6.3 will have a forward-compatibility fix to address that Visual Studio issue.
Thu Aug 30, 2012 8:28 am View user's profile Send private message
Ahsan12



Joined: 22 Oct 2014
Posts: 1
Country: Pakistan

Post Reply with quote
I'm on Windows 7 x64 and Visual Studio 2010 SP1. UAC is turned off and my user is an Administrator. SQL Assist was installed using the Professional option. I only want to use it with SSMS, not Visual Studio or anything else.

I let the SQL Assist update automatically, now Visual Studio starts with the error http://www.vceplayer.com/simulator/how-to-open-vce-files.html
"The 'Visual Studio Component Model Host Package' package did not load correctly." It freezes, then crashes if I open a solution. If I start Notepad++, it uses a bunch of RAM and CPU, but the GUI never appears.

I tried un-checking Visual Studio and Notepad++ in the SQL Assist config. This allows Notepad++ to start, but Visual Studio does the exact same thing.

I uninstall SQL Assist everything works. When I reinstall, the same thing happens again.
Wed Oct 22, 2014 2:20 am View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.