SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
Cannot connect to database

 
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant View previous topic
View next topic
Cannot connect to database
Author Message
ssandu



Joined: 26 Feb 2007
Posts: 95
Country: Romania

Post Cannot connect to database Reply with quote
After testing beta version for a long time when I installed the final version I cannot connect to working database.
I hit connect and it's showing the connect window again.
I've tried using ADO.NET, ODBC and AutoDetect but same simptoms.
I am using SQL Server 2005 and Vista.
Reinstalling ver. 2.5 work's fine.
Any ideas please ?
Thank's
Mon Dec 10, 2007 10:05 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6499

Post Reply with quote
Please set the connection method to Auto-detect. The connection type option is mostly for people using the config screen for setting the API interface.

If SQL Assistant is installed in multiple locations, please Close all targets and remove old installations. In SQL Assistant's Options, select SSMS target, for SSMS target uncheck Register Add-on and click the Apply button. Check the add-on option again and click the Apply again. Please let us know if this helps.
Mon Dec 10, 2007 1:45 pm View user's profile Send private message
ssandu



Joined: 26 Feb 2007
Posts: 95
Country: Romania

Post Reply with quote
Yes it's working now.
Thank's a lot
Tue Dec 11, 2007 3:30 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6499

Post Reply with quote
Great!
Tue Dec 11, 2007 12:04 pm View user's profile Send private message
ssandu



Joined: 26 Feb 2007
Posts: 95
Country: Romania

Post Reply with quote
Sorry but now I have another problem.
I can't change Code Formatting Style for MS Management Studio.
It's by default MySQL Default Style. After I change it's working for that session but aftre I restart Sql Assistant it still MySQL Default Style.
I've tried to change on Options|Targets and on Modify Target Options.
Thank's
Wed Dec 12, 2007 6:52 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6499

Post Reply with quote
It sounds like you got corrupted or write protected sqlassist.sas config file. Please check if you got multiple copies of this file. If yes, please delete extra copies. If not, I suggest deleting it and reinstalling the software.
Wed Dec 12, 2007 10:26 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6499

Post Reply with quote
Are you running it on Vista by any chance?

Vista is known to do many undesired things such as configuration file caching.
Wed Dec 12, 2007 10:29 am View user's profile Send private message
ssandu



Joined: 26 Feb 2007
Posts: 95
Country: Romania

Post Reply with quote
Yes I am using Vista.
Any chanses to make it work ?
Now every time I start SQL Assistant I change back these settings.
Thank's
Thu Dec 13, 2007 2:43 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6499

Post Reply with quote
Do you have it installed in the default "C:\Program Files\SQL Assistant" folder or some other place?
Thu Dec 13, 2007 10:51 am View user's profile Send private message
ssandu



Joined: 26 Feb 2007
Posts: 95
Country: Romania

Post Reply with quote
Yes
Should I install it on another folder ?
Fri Dec 14, 2007 2:58 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6499

Post Reply with quote
Give me some time to experiment with various Vista settings. I am looking for settings affecting config file caching, roaming profiles and similar things.
Fri Dec 14, 2007 10:24 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6499

Post Reply with quote
Unfortunately I didn't find anything affecting the SQL Assistant configuration file and was unable so far to reproduce this issue. I suggest the following:

If the problem is only specific to the formatting style
1. Shutdown SQL Assistant and all target SQL editors.
2. Open SQLAssist.sas file in Notepad
3. Search for "MS Management Studio" text (without quotes)
4. In the found section, locate line starting with the name "rules=" and replace text after the equal sing with "T-SQL Default Style" or whatever style name you want to use as the default. Be careful not to replace special end-of-line symbols.
5. Save changes and close the file.
6. Start SQL Assistant and check in the Options if the manual changes have been saved.


If the above doesn't help, please uninstall SQL Assistant, manually delete any remaining files from its installation directory and reinstall it.
Fri Dec 14, 2007 11:36 am View user's profile Send private message
ssandu



Joined: 26 Feb 2007
Posts: 95
Country: Romania

Post Reply with quote
SysOp wrote:
In the found section, locate line starting with the name "rules=" and replace text after the equal sing with "T-SQL Default Style" or whatever style name you want to use as the default. Be careful not to replace special end-of-line symbols.

It was already "T-SQL Default Style" but I don't know why at start in the options was My Sql.
I think it's something with Vista.
I've reinstalled it (after uninstall and delete all remaining files) and it's working fine now.
Thank's again for support.
Sorin
Mon Dec 17, 2007 5:16 am View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6499

Post Reply with quote
Thanks for the update. I'm glad this issue is resolved now and it is working for you.
Mon Dec 17, 2007 9:16 am View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.