SoftTree Technologies SoftTree Technologies
Technical Support Forums
RegisterSearchFAQMemberlistUsergroupsLog in
Cannot select choice of authentication for SqlServer

 
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant View previous topic
View next topic
Cannot select choice of authentication for SqlServer
Author Message
msorens



Joined: 29 Jan 2007
Posts: 12
Country: us

Post Cannot select choice of authentication for SqlServer Reply with quote
I have a custom windows application. I started that up, then right-clicked SqlAssist tray icon, and selected Target >> Modify Target Options, and selected from the 3 dropdowns on the Options tab. Closing that, I then typed "select" into my application window. At the final letter, Sql Assistant popped up a connection box, allowing me to specify a server but not a user name/pwd (i.e. only windows authentication). I entered a server name anyway, but as expected it failed. I even tried the default "(local)" to try a different database but that also failed with a SqlDriverConnect, ODBC error, db does not exist or failed to connect, etc.
I tried with both SqlServer 2000 and 2005 options.

My custom application happens to be a dual Oracle/SqlServer tool. So I then switched Sql Assistant to Oracle. This time, it did ask for name, login, and TNS, and it connected just fine.

Other details:
I had no problem using Sql Assist from SqlServer Mgmt Studio Express.

Version: Sql Assistant version 2.0.10 beta
Wed Apr 18, 2007 7:05 pm View user's profile Send private message
SysOp
Site Admin


Joined: 26 Nov 2006
Posts: 6508

Post Reply with quote
You likely selected wrong options and as a result, SQL Assistant incorrectly identified your application confusing it with something else. Now it treats it as an application using Windows authentication and so the user/password options are disabled.

Here is what you should do. First, delete the registered target profile. Start your application, place cursor into the editor window, make sure it has focus, press CTLR+F5 hot key to register the active target. Open up SQL Assistant options and modify database connection and environment as required.
Wed Apr 18, 2007 7:17 pm View user's profile Send private message
msorens



Joined: 29 Jan 2007
Posts: 12
Country: us

Post Reply with quote
Thanks, but your suggested fix did not work. What did work is that I noticed the >> in the connect box. Clicking that, I could then switch from Windows to SqlServer authentication, and that did the trick.
Thu Apr 19, 2007 1:02 pm View user's profile Send private message
Display posts from previous:    
Reply to topic    SoftTree Technologies Forum Index » SQL Assistant All times are GMT - 4 Hours
Page 1 of 1

 
Jump to: 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


 

 

Powered by phpBB © 2001, 2005 phpBB Group
Design by Freestyle XL / Flowers Online.